Team Foundation Task Board Enhancer: version .7.6 released


Facebooktwitterlinkedin

 

New release of my Team Foundation Task Board Enhancer (previous versions .7.5, .7, 2.6.2 (update2 only), 0.6.1, 0.6 , 0.5 , 0.4 , 0.3 , 02 and 0.1 ).

If you want to know what is Task Board Enhancer or want to see the full list of features, head on to the Task Board Enhancer page

 

New Features in this release

There are no new features in this release. It’s just a bug fixing release.

In the previous version, I did an optimization for modern browser to make it a little faster in the process I’ve broke Internet Explorer 8 support (every time I do a release, I test it with only the newest version Chrome, IE 9 and 10 and Firefox).

So if you are using version 2.7.5 and Internet Explorer 8 this is for you (version 0.7.5 didn’t had the issue).

I’ve had a bug report with Firefox but couldn’t reproduce (the user didn’t specify the version he was using) so this may also fix the same issue on older Firefox versions.

Download

There are two different versions, depending if you are already running TFS 2012 with update 2 or 3 or an older 2012 version (RTM or Update 1).

For Update 2 and upwards Download version 2.7.6 of the extension

For RTM and Update 1  Download version 0.7.6 of the extension

Facebooktwitterlinkedin

0 thoughts on “Team Foundation Task Board Enhancer: version .7.6 released

  1. Hi Tiago,

    Thank you very much for this useful tool.

    I noticed that in version 2.7.6, if you click “team members” then go back to “backlog items” the work item ID and state does not show on the parent work items until you refresh your browser. This is a problem in IE 10 and Firefox 21.0.

  2. Looks like the extension doesn’t work with TFS 2013 preview. Please make it so. Your add-in is making us consider NOT upgrading to TFS 2013 until this plug-in is working. Thx.

  3. Hi Tiago,

    We’re running into a bit of an issue with the Task Board Enhancer on IE 9 which may or may not be related to the issue you heard of before. Whenever we open up a new instance of IE 9 and immediately make a change to an item on the task board, this error is thrown on screen: “Unable to get value of the property ‘payload’: object is null or undefined”. We have tried reproducing the issue on all other modern browsers, but only IE 9 is complaining (even IE 10 works). All Task Board Enhancer versions from 2.6.2 to 2.7.6 produce this error.

    Other info:
    -IE9 Version: 9.0.8112.16421
    -IE Update Versions 9.0.18 (KB2846071)
    -64 Bit OS (64 Bit IE)

    Please don’t hesitate to contact me if you need any more information.

    1. Thanks for the report.

      Going to try to reproduce it on my lab.

      how are you “immediately make change” ? drag & drop? open the WI form? changing remaining work?

      If you “wait” some time, does it work?

      Thanks

      1. Thanks for the speedy response!

        Here are the exact steps that were used to produce the error:

        1. Start up new session in IE 9 (no currently open browsers)
        2. Navigate to URL: http://[SERVER]/tfs/%5BCOLLECTION%5D/%5BPROJECT%5D/_boards#
        3. Board loads but Team Enhancement Board does not appear to have loaded
        a. Visual top bar is not visible
        4. Open WorkItem for Edit (from Board)
        a. Edit a field
        b. Save WorkItem (using Save)
        5. Error occurs
        a. Unable to get value of the property ‘payload’: object is null or undefined

        Seems to have something to do with the task board not always loading when page is setup. Note that this can be reproduced by drag & drop and changing the remaining work on the board as well. Waiting doesn’t make a difference; I only meant “immediately” in the sense that you don’t make changes elsewhere (queries, WI creation, etc.) beforehand. As you may guess, the error will not occur if you refresh the page after loading the browser since the Task Board Enhancer reloads with it.

        Side Note: Only other extension running on Web Access is Advanced Code Editor Extension.

          1. Was this resolved? If so, would you mind posting the resolution for others that are experiencing the same error message when using the task board? Thanks in advance.

          2. Although i have never been able to reproduce this error on my test environment i do believe this has been fixed on version 2.7.7

            Have you upgraded to 2.7.7?

            Thanks

  4. I would really like to turn this plugin on and off on a per project/per collection basis. We have serveral collections and each has as many as 40 projects. This could be a simple xml config file. If this is possible that would be great. Thanks!

    1. that is a little behind my control, since its controlled at the server level. i could place some controls at the client level. but they weak.

  5. Would it be possible to have different colors on kanban board for each work item type (PBI, Bug, etc)?

    Thanks,

    Pablo

Leave a Reply

Your email address will not be published. Required fields are marked *